Mercedes AMG Limp Mode - Mercedes AMG GT Forum
User Tag List

 
Thread Tools
post #1 of 5 (permalink) Old 04-12-2018, 11:06 AM Thread Starter
Senior Member
 
Join Date: Aug 2015
Posts: 139
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
(Thread Starter)
Mercedes AMG Limp Mode

Was chatting with my buddy while he did some maintenance on my SUV and we got onto the topic of maintenance costs for certain models like the Mercedes AMG. He mentioned something about the AMG being prone to transmission problems when pushed hard on track and going into limp mode. Is this a concern for the AMG GT?
InHouseSpecial is offline  
post #2 of 5 (permalink) Old 04-18-2018, 01:36 PM
Member
 
Join Date: Jan 2018
Posts: 32
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
That's the first I'm hearing about it. I've heard similar problems with Z06 Corvettes. There is actually a class action lawsuit that's underway from owners and they traced the problem back to a cooling system defect. Basically renders the car useless after 15 minutes of track driving.
Onyourleft is offline  
post #3 of 5 (permalink) Old 04-19-2018, 09:21 AM
Junior Member
 
90sundevil's Avatar
 
Join Date: Sep 2017
Location: Scottsdale
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Quote:
Originally Posted by Onyourleft View Post
That's the first I'm hearing about it. I've heard similar problems with Z06 Corvettes. There is actually a class action lawsuit that's underway from owners and they traced the problem back to a cooling system defect. Basically renders the car useless after 15 minutes of track driving.
That problem only happened in the auto Z06 as they did not have the same cooling that the 7 speeds did. My guess it is an engine cooling issue. Did I mention how horrible the auto is in the Z06, if it was like my AMG or Porsche PDK I would still have it and not get rid of the beast in 6 months. Just could not get use to that truck transmission in such a great car.
90sundevil is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 04-19-2018, 11:37 AM Thread Starter
Senior Member
 
Join Date: Aug 2015
Posts: 139
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
(Thread Starter)
Maybe it was for some other Mercedes model where limp mode occurs more than expected because I don't see AMG owners having this problem. Never drove a Z06, but I'll take your word for it and steer away from that specific model, though the new gen Corvette does look appealing.
InHouseSpecial is offline  
post #5 of 5 (permalink) Old 04-25-2018, 01:30 PM
Member
 
Join Date: Jan 2018
Posts: 32
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
I didn't realize it was only a problem in the automatics. And I definitely agree that the new ZR1's look pretty incredible. I saw for the 2019 model, that it has an official top speed of 212mph.
Onyourleft is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes AMG GT Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
>
For the best viewing experience please update your browser to Google Chrome